Solución al problema "Incorrect language dll ...Please reinstall MapInstall"

despista2

Curveando
Registrado
13 Nov 2013
Mensajes
3.612
Puntos
113
Ubicación
La Gipuzkoa profunda
Lo he comentado en otro hilo, pero alguno más me lo ha planteado por privado, por lo que lo cuelgo aquí para que que se encuentre más fácil.

Algunos de los que estáis intentando instalar mapas en el ordenador para usarlos con BaseCamp (por ejemplo, mapas Topo o mapas sacados de OpenstreetMaps), bien sea usando MapInstall o, directamente, desde BaseCamp (que lanza MapInstall para ello), os podéis estáis encontrando con el siguiente mensaje de error:

"Incorrect language dll........Please reinstall Mapinstall"

Y no se arregla reinstalando MapInstall, al menos en su ultima versión.

¿Porqué ocurre?

Porque, en algún momento, habéis actualizado la versión de MapInstall a la 4.20, la última disponible. Y es esta versión de MapInstall la causante del error.

Puede que hayáis actualizado directamente, porque al abrir las versiones anteriores de MapInstall avisa que hay una versión nueva y pide que se actualice.

Pero también puede que no os hayáis dado cuenta pero que, en algún momento, hayáis actualizado BaseCamp a la version 4.7. Y, en esa actualización, se actualiza MapInstall a la versión 4.20 automáticamente.

Y, aunque hayáis vuelto a BaseCamp 4.6.2 posteriormente, como hemos hecho unos cuantos, Mapinstall se mantiene en la versión 4.2.0.

Solución: volver a la versión anterior de MapInstall, la 4.0.4.

Pasos a seguir:

- Ir a la carpeta C:\Program Files (x86)\Garmin\MapInstall\ (según el ordenador, puede que sea Archivos de Programa en vez de Program Files)

- Borrar todos los ficheros que haya en la carpeta MapInstall pero OJO, no borrar las subcarpetas. Sobre todo, no borrar la subcarpeta MAPS.

- Bajar el instalador de Mapinstall 4.0.4 de aquí y ejecutarlo.

https://www8.garmin.com/software/MapInstall_404.exe

- Ojo, la siguiente vez que abráis MapInstall intentará que actualicéis a la 4.2.0 (al igual que hace BaseCamp 4.6.2). Le dais al botón de Mas adelante, al igual que hay que hacerlo en BaseCamp 4.6.2 para evitar que actualice, y a correr.
 

juancarlos.parra

Allá vamos
Registrado
11 Feb 2018
Mensajes
681
Puntos
63
Ubicación
Estella
redios yo no toco nada que jodo todo jajaja gracias, por cierto suelo ir a elgoibar, a ver si un dia te conozco y te doy las gracias en persona
 

pubes

En rodaje
Registrado
22 Jul 2013
Mensajes
146
Puntos
18
Gracias por dar luz a los que estamos ciegos.
Saludos
 

malara

Arrancando
Registrado
8 Feb 2019
Mensajes
2
Puntos
3
Ubicación
madrid
Como acabo de decir en mi presentación, acabo de llegar aquí por casualidad, pero lo primero que quería hacer es agradecer a despista2 su comentario.

Quizás a otros mas preparados les parezca fácil, pero a mi me acaba de sacar de un apuro.

Gracias.
 

eduomedes

Arrancando
Registrado
14 Feb 2014
Mensajes
93
Puntos
18
Lo he comentado en otro hilo, pero alguno más me lo ha planteado por privado, por lo que lo cuelgo aquí para que que se encuentre más fácil.

Algunos de los que estáis intentando instalar mapas en el ordenador para usarlos con BaseCamp (por ejemplo, mapas Topo o mapas sacados de OpenstreetMaps), bien sea usando MapInstall o, directamente, desde BaseCamp (que lanza MapInstall para ello), os podéis estáis encontrando con el siguiente mensaje de error:

"Incorrect language dll........Please reinstall Mapinstall"

Y no se arregla reinstalando MapInstall, al menos en su ultima versión.

¿Porqué ocurre?

Porque, en algún momento, habéis actualizado la versión de MapInstall a la 4.20, la última disponible. Y es esta versión de MapInstall la causante del error.

Puede que hayáis actualizado directamente, porque al abrir las versiones anteriores de MapInstall avisa que hay una versión nueva y pide que se actualice.

Pero también puede que no os hayáis dado cuenta pero que, en algún momento, hayáis actualizado BaseCamp a la version 4.7. Y, en esa actualización, se actualiza MapInstall a la versión 4.20 automáticamente.

Y, aunque hayáis vuelto a BaseCamp 4.6.2 posteriormente, como hemos hecho unos cuantos, Mapinstall se mantiene en la versión 4.2.0.

Solución: volver a la versión anterior de MapInstall, la 4.0.4.

Pasos a seguir:

- Ir a la carpeta C:\Program Files (x86)\Garmin\MapInstall\ (según el ordenador, puede que sea Archivos de Programa en vez de Program Files)

- Borrar todos los ficheros que haya en la carpeta MapInstall pero OJO, no borrar las subcarpetas. Sobre todo, no borrar la subcarpeta MAPS.

- Bajar el instalador de Mapinstall 4.0.4 de aquí y ejecutarlo.

https://www8.garmin.com/software/MapInstall_404.exe

- Ojo, la siguiente vez que abráis MapInstall intentará que actualicéis a la 4.2.0 (al igual que hace BaseCamp 4.6.2). Le dais al botón de Mas adelante, al igual que hay que hacerlo en BaseCamp 4.6.2 para evitar que actualice, y a correr.




Sera la edad pero no lo logro. Debajo de la carpeta de Maps hay unas carpetas en blanco. estas se han de borrar¿ Si son estas no lo consigo, qye he de hacer? Si voy al enlace para instalar al abrir me vuerlve a dar el mismo error,
Muchas graciass
2019-04-08.png
 

despista2

Curveando
Registrado
13 Nov 2013
Mensajes
3.612
Puntos
113
Ubicación
La Gipuzkoa profunda
Sera la edad pero no lo logro. Debajo de la carpeta de Maps hay unas carpetas en blanco. estas se han de borrar¿ Si son estas no lo consigo, qye he de hacer? Si voy al enlace para instalar al abrir me vuerlve a dar el mismo error,
Muchas graciass
Ver el archivo adjunto 134725

Borra todos los ficheros que se ven en la imagen, pero dejando la carpeta MAPS (y su contenido) sin tocar.

Luego descargas el fichero .exe del enlace y lo ejecutas.

Así lo hice yo y me funcionó.
 

eduomedes

Arrancando
Registrado
14 Feb 2014
Mensajes
93
Puntos
18
Gracias, como siempre eres un crack. Lo logré al final
 

angel_2ruedas

Curveando
Registrado
8 Nov 2004
Mensajes
1.002
Puntos
38
Ubicación
Madrid... y alrededores
Lo he comentado en otro hilo, pero alguno más me lo ha planteado por privado, por lo que lo cuelgo aquí para que que se encuentre más fácil.

Algunos de los que estáis intentando instalar mapas en el ordenador para usarlos con BaseCamp (por ejemplo, mapas Topo o mapas sacados de OpenstreetMaps), bien sea usando MapInstall o, directamente, desde BaseCamp (que lanza MapInstall para ello), os podéis estáis encontrando con el siguiente mensaje de error:

"Incorrect language dll........Please reinstall Mapinstall"

Y no se arregla reinstalando MapInstall, al menos en su ultima versión.

¿Porqué ocurre?

Porque, en algún momento, habéis actualizado la versión de MapInstall a la 4.20, la última disponible. Y es esta versión de MapInstall la causante del error.

Puede que hayáis actualizado directamente, porque al abrir las versiones anteriores de MapInstall avisa que hay una versión nueva y pide que se actualice.

Pero también puede que no os hayáis dado cuenta pero que, en algún momento, hayáis actualizado BaseCamp a la version 4.7. Y, en esa actualización, se actualiza MapInstall a la versión 4.20 automáticamente.

Y, aunque hayáis vuelto a BaseCamp 4.6.2 posteriormente, como hemos hecho unos cuantos, Mapinstall se mantiene en la versión 4.2.0.

Solución: volver a la versión anterior de MapInstall, la 4.0.4.

Pasos a seguir:

- Ir a la carpeta C:\Program Files (x86)\Garmin\MapInstall\ (según el ordenador, puede que sea Archivos de Programa en vez de Program Files)

- Borrar todos los ficheros que haya en la carpeta MapInstall pero OJO, no borrar las subcarpetas. Sobre todo, no borrar la subcarpeta MAPS.

- Bajar el instalador de Mapinstall 4.0.4 de aquí y ejecutarlo.

https://www8.garmin.com/software/MapInstall_404.exe

- Ojo, la siguiente vez que abráis MapInstall intentará que actualicéis a la 4.2.0 (al igual que hace BaseCamp 4.6.2). Le dais al botón de Mas adelante, al igual que hay que hacerlo en BaseCamp 4.6.2 para evitar que actualice, y a correr.

1º de todo gracias por darnos luz ;-)

Esta semana he empezado con problemas, he vuelto al BaseCamp 4.6.2 (todo correcto), y evidentemente también me he puesto a volver a la versión anterior del MapInstall. Pero tras seguir tus pasos, ejecutando el .exe de la 4.0.4 recién descargada, me salta un error:

MSI Error: InstallFailure

y evidentemente no la instala.

¿Alguna sugerencia?

Un saludo,

Ángel "2 Ruedas"
 
Arriba